Cosmic Global - Elevated Latency on US-Europe traffic – Incident details

Elevated Latency on US-Europe traffic

Resolved
Operational
Started over 1 year agoLasted about 4 hours

Affected

Network Points of Presence

Operational from 3:41 AM to 7:27 AM

Los Angeles, California

Operational from 3:41 AM to 7:27 AM

Dallas, Texas

Operational from 3:41 AM to 7:27 AM

Ashburn, Virginia

Operational from 3:41 AM to 7:27 AM

London, United Kingdom

Operational from 3:41 AM to 7:27 AM

Amsterdam, Netherlands

Operational from 3:41 AM to 7:27 AM

Updates
  • Resolved
    Resolved

    Our carriers seem to have routed around the problem with minimal latency. We're marking this incident as closed.

  • Investigating
    Investigating

    Hi Everyone,

    We're currently experiencing elevated latencies on traffic going between Europe and the U.S.

    Our NOC is actively engaging with our carriers to figure out what's going on, as well as an ETA on a remedy.