Cosmic Global - Network Instability – Incident details

Network Instability

Monitoring
Degraded performance
Started 3 days ago

Affected

Network Points of Presence

Operational from 7:13 PM to 12:00 AM

Los Angeles, California

Operational from 7:13 PM to 12:00 AM

Dallas, Texas

Operational from 7:13 PM to 12:00 AM

Ashburn, Virginia

Operational from 7:13 PM to 12:00 AM

London, United Kingdom

Operational from 7:13 PM to 12:00 AM

Amsterdam, Netherlands

Operational from 7:13 PM to 12:00 AM

Updates
  • Update
    Update

    We are continuing to work on the situation and monitor potential issues and apply fixes as needed.

  • Monitoring
    Monitoring

    Dear Cosmic Clients,

    We just wanted to shed some light on the situation over the past 24 hours.

    Initially, we were dealing with some very large DDoS attacks, which caused certain issues. The attacks ranged in sizee from 1.5Tbps to 2.5Tbps and totaled about 35-40 in a 16 hour period so far. These attacks were mostly handled, however, an emergency script on our side subsequently triggered a subnet-wide connectivity issue for a few subnets. We've since patched the script and restored connectivity.

    Additionally, we have multiple Tbps of extra capacity pending delivery and handoff, which should be completed shortly to deal with the increasing cyber threat landscape we find ourselves in.

    We’ll be working diligently around the clock to keep things stable.

    We truly appreciate your loyalty—things will be back to normal soon.